Ankündigung

Einklappen
Keine Ankündigung bisher.

NC3 startet nicht per Fernbedienung - nur direkt per Powertaste am Gerät

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • NC3 startet nicht per Fernbedienung - nur direkt per Powertaste am Gerät

    Erst hatte ich meiner besseren Hälfte nicht gegleubt ;-) aber es kommt tats. jedes x. mal vor, dass man nicht per FBD aus dem DeepStandby starten kann. Ich hatte es auch mit der FBD meiner AVG1 vesucht.
    Mit der Fronttatste funktioniert dann der Start.

    Kennt ihr das ? Wo könnte ich (Elektroniker) mit der Suche starten ?

  • #2
    Hallo pll,
    hast Du es mal mit einem Satz neuer Batterien versucht ( http://powersat.de/showthread.php?63...t-m%C3%B6glich ) ?

    Gruss,
    schlue
    sigpic

    Kommentar


    • #3
      wie gesagt: Ich hatte es auch mit der FBD meiner AVG1 vesucht ... aber ich werde das jedenfalls noch probieren. Die Spannung der Batterien ist unter Last 1,46V

      Kommentar


      • #4
        Zitat von pll Beitrag anzeigen
        wie gesagt: Ich hatte es auch mit der FBD meiner AVG1 vesucht ... aber ich werde das jedenfalls noch probieren. Die Spannung der Batterien ist unter Last 1,46V
        In Reihe oder einzeln? Hatte das auch vor ein paar Monate. Die Batterien hatten unterschiedliche Spannungen. Beim Messen nichts auffälliges. Aber mit neuen wieder alles OK.
        Gruß Henner

        Spiegel - Technisat Satman 85, 2x ALPS Quattro LNB BSTE9,
        Multiswitch - Inverto Unicable IDLP-USS200-CU010-8PP, Spaun 9940NF, Spaun 9800NF (DVB-T Einspeisung, alle MS kaskadiert - 14 DiSEqC, 8 Unicable Anschlüsse),
        ext NetCeiver mit 5 DVB-S2 Tuner, AVG III, NCL II, NCL I,
        NAS QNAP TS-431 mit 3x 3TB WD red

        Kommentar


        • #5
          Hab mir gedacht, ich frag mal, ob es noch mittlerweile mehr User mit dem Prob gibt ...

          Bei mir ist es immer noch ein sporadisches Phänomen und ja mit ganz neuen Battereien geht es. Trotzdem ist da was faul, da die gleiche FBD meine AVG1 problemlos bedient und umgkehrt die AVG1 FBD den NCL2 in solchen Situationen auch nicht einschalten kann...

          Kommentar


          • #6
            Ich hab das Prob trotz Tausch des Frontpanels immer noch. Ich nehme an dass die Frontpaneltaste ein Wakeup über USB auslöst ...

            1. und wie funktioniert das über den IR-Empfänger ? Das geht ja über das Flachbandkabel ... und dann ???

            2. Hab ich ein Hardware oder Softwareprob ??

            3. Wie könnte ich den Fehler eingrenzen (z.B. wenn der NCL2 gerade nicht reagiert ..) ?
            Zuletzt geändert von pll; 28.02.2014, 19:26.

            Kommentar


            • #7
              Es ist hardwareunabhängig, da es auch bei einem Neuen NCL2 auftritt !

              Ich hab jetzt mal den USB Stick gezogen. Da lässt sich der NCL2 nur noch über die Taste einschalten. Das spricht doch dafür, dass beim runter fahren ein Flag/Register gesetzt wird, das den Wakeup per FBD erst ermöglicht.
              Das IR Signal liegt auf Pin 5 und die Taste auf Pin 13 des Flachbandkabels.

              Kommentar


              • #8
                sowohl IR-Signal als auch FP-Taste gehen zum PIC = U18 (links oberhalb des nachträglich aufgelöteten Elkos)

                Kommentar


                • #9
                  Hallo pll,
                  was meinst Du mit
                  hardwareunabhaengig, da es auch bei einem neuen NCL2 auftritt
                  Du besitzt zwei Geraete bei denen der identische Fehler auftritt ?

                  Ich kenne die Funktion / den Aufbau nicht.
                  Mein(e) Verstaendnis/Vermutung ist:
                  - die Box befindet sich im DeepStandBy
                  - nur ein minimaler Teil der Box wird mit Spannung versorgt z.B. das Frontpanel
                  - und der PIC ?
                  - das Frontpanel decodiert die IR Signale
                  - ein Einschaltsignal vom Frontpanel ( erkanntes IR einschalten bzw. Taste ) wird an den PIC weitergeleitet
                  - der PIC gibt ein erkanntes Einschaltsignal als Power On an das Netzteil weiter

                  Zu welchem Zeitpunkt hast Du den USB Stick abgezogen ? Im eingeschalteten Zustand ?

                  Gruss,
                  schlue
                  sigpic

                  Kommentar


                  • #10
                    Die IR-Signale gehen jedenfalls auch in den PIC ...

                    1 Ich fahre per FBD "Ausschalten" runter. Dann ziehe ich den Stick der vorne in der Front steckt.
                    >> kein Start per FPD aber per Taste (natürlich kommt er nicht weit ;-). Auch wenn ich den Stick wieder einstecke kein Start per FBD, jedoch per Fronttaster. Fährt dann normal hoch.

                    2 Stick im DeepSTB von außen nach innen >> startet per FBD

                    3 Stick innen abgezogen >> kein Start per FBD. Auch nicht nach Stick rein. Per Fronttaste Start OK.
                    Zuletzt geändert von pll; 02.03.2014, 12:44.

                    Kommentar


                    • #11
                      Sobald man also ohne Stick per FBD zu starten versucht, ist kein weiterer Start per FBD möglich. Sehr wohl aber per Fronttaster oder im Fall von 2 (geht auch umgekehrt = Tausch von Innen nach Außen), wo ich nicht ohne Stick zu starten versucht habe.
                      Zuletzt geändert von pll; 02.03.2014, 12:50.

                      Kommentar


                      • #12
                        Jetzt ist er nach abziehen des Sticks (innen) auch per FBD gestartet. Das geht genau 1x. Dann nur noch Taster .... how come ???? Inkonsistent ...
                        Zuletzt geändert von pll; 02.03.2014, 12:58.

                        Kommentar


                        • #13
                          Zitat von pll
                          gibt's eigentlich eine Möglichkeit die PIC / Frontpanel Version des NCL2 auszulesen ??
                          Zitat von schlue
                          Hallo,
                          da ich selber keinen NCL II besitze, der NCL ( zumindest vom Mainboard ) mit der AVG III identisch ist koenntest Du folgendes versuchen:
                          Code:
                          dpkg -L reelbox-frontpanel | grep main.flash
                          dies liefert bei mir
                          Code:
                          /usr/share/reel/frontpanel/main.flash-1.20
                          sollte daher Version 1.20 der Frontpanel Firmware sein.
                          Das Paket traegt die Version
                          Code:
                          dpkg -l reelbox-frontpanel
                          Code:
                          ||/ Name                                        Version                                     Beschreibung
                          +++-===========================================-===========================================-======================================================================================================
                          ii  reelbox-frontpanel                          4.2.1-13                                    Tools needed by the ReelBox frontpanel

                          Laeuft bei Dir dieser Prozess
                          Code:
                          ps -ef | grep -i frontpnael
                          sollte liefern
                          Code:
                          root      4496     1  0 17:28 ?        00:00:07 /usr/sbin/reelbox-ctrld -f -d /dev/frontpanel -X udp:2003
                          Erst den NCL in den Wartungsmodus bringen, dann mit
                          Code:
                          service reelvdr stop
                          den Frontpanel Service stoppen, einen Moment warten u. mit
                          Code:
                          reelfpctl -getversion
                          die Version mit Hilfe der Software aus dem Frontpanel auslesen.
                          Das funktioniert zumindest auf der AVG III.
                          Der NCL ist in diesem Zustand nicht mehr ueber die Fernbedienung bzw. die Tasten ansprechbar, d.h. Zugang ueber RCC/telnet muss vorher vorbereitet sein.

                          Ob bzw. wie man die PIC Version auslesen kann ist mir nicht bekannt. Ich vermute, dass man dazu eine/die Service Schnittstelle benutzen muss, wenn diei Version ausgelesen werden kann.

                          Gruss,
                          schlue
                          Danke schlue !

                          Mein Ergebnis: 1.20 und 4.2.1-13 ident .... Die Unterschiede beginnen hier:
                          Code:
                          root@ReelBox:~# ps -ef | grep -i frontpanel                                    
                          root      4360     1  0 11:48 ?        00:00:05 /usr/sbin/reelbox-ctrld -f -d /dev/frontpanel -X udp:2003                                                      
                          root      6520  5783  0 12:05 pts/0    00:00:00 grep --color -i frontpanel
                          Code:
                          reelfpctl -getversion
                          gibt am NCL2 keine Rückmeldung

                          TOP liefert bei gestoppten reelvdr:
                          Code:
                            PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
                           4184 root      RT   0     0    0    0 S    1  0.0   0:09.32 Clock_ISR         
                           7026 root      20   0  2592 1100  820 R    1  0.1   0:00.34 top               
                           4293 root      RT   0     0    0    0 S    0  0.0   0:11.54 DisplayInterrup   
                           4294 root     -71   0     0    0    0 D    0  0.0   0:07.98 DisplayVBI        
                           4360 root      20   0 60676  636  356 S    0  0.0   0:07.90 reelbox-ctrld     
                           4360 root      20   0 60676  636  356 S    0  0.0   0:07.90 reelbox-ctrld     
                           4633 root     -81   0     0    0    0 S    0  0.0   0:11.67 Audio_Timing      
                           4759 root     -71   0     0    0    0 S    0  0.0   0:22.42 VidRend_IO        
                              1 root      20   0  2940 1768 1204 S    0  0.1   0:01.40 init              
                              2 root      20   0     0    0    0 S    0  0.0   0:00.00 kthreadd          
                              3 root      20   0     0    0    0 S    0  0.0   0:00.50 ksoftirqd/0       
                              3 root      20   0     0    0    0 S    0  0.0   0:00.50 ksoftirqd/0       
                              4 root      20   0     0    0    0 S    0  0.0   0:00.06 kworker/0:0       
                              5 root      20   0     0    0    0 S    0  0.0   0:00.06 kworker/u:0       
                              6 root      RT   0     0    0    0 S    0  0.0   0:00.00 migration/0       
                              7 root      RT   0     0    0    0 S    0  0.0   0:00.00 migration/1       
                              9 root      20   0     0    0    0 S    0  0.0   0:00.10 ksoftirqd/1       
                              9 root      20   0     0    0    0 S    0  0.0   0:00.10 ksoftirqd/1       
                             11 root       0 -20     0    0    0 S    0  0.0   0:00.00 khelper           
                            183 root      20   0     0    0    0 S    0  0.0   0:00.00 sync_supers
                          - Auf die PIC Version wird man so nicht kommen oder ?

                          - Ob beim Herunterfahren ein Befehl an den PIC bez. nächsten Start geht - wie könnte ich das rausfinden ???




                          EDITed by schlue: Zeilenumbruch geloescht
                          Zuletzt geändert von schlue; 08.03.2014, 13:22.

                          Kommentar


                          • #14
                            rc0, 2

                            rc0
                            rc0_1.PNGrc0_1.PNG
                            rc2
                            rc2.PNG
                            welcher Aufruf könnte es sein oder bin ich an der falschen Stelle ?
                            Zuletzt geändert von pll; 08.03.2014, 12:51.

                            Kommentar


                            • #15
                              Hallo pll,
                              Mein Ergebnis: 1.20 und 4.2.1-13 ident .... Die Unterschiede beginnen hier:
                              Code:
                              root@ReelBox:~# ps -ef | grep -i frontpanel                                     
                              root      4360     1  0 11:48 ?        00:00:05 /usr/sbin/reelbox-ctrld -f -d /dev/frontpanel -X udp:2003                                                       
                              root      6520  5783  0 12:05 pts/0    00:00:00 grep --color -i frontpanel
                              das ist ok. Die zweite Zeile habe ich unterschlagen. Sie stellt lediglich dar, dass auch der grep Befehl selber in der aktuellen Prozessliste gefunden wurde.

                              Der reelbox-ctrld ist noch in Deiner Prozessliste, die Du mit Top generiert hast zu finden. Solange reelbox-ctrld noch laeuft liefert der Aufruf mit -getversion keine Versionsinformation zurueck.

                              Vor dem Ausfuehren des service Befehles hast Du den NCL in den Wartungsmodus versetzt ?

                              Ich weiss nicht, ob es moeglich ist die PIC Version auszulesen.
                              Um der Ursache Deines Problemes naeher zu kommen muesstest Du vermutlich Unteruschungen mit einem Osziloskop durchfuehren.


                              Gruss,
                              schlue
                              sigpic

                              Kommentar

                              Lädt...
                              X