Ankündigung

Einklappen
Keine Ankündigung bisher.

Permanent Timeshift auf die Nas legen

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Permanent Timeshift auf die Nas legen

    Hallo,

    ich will mein Netclient2 ohne Festplatte nutzen und trotzdem die Timeshift Funktion nutzen.
    Aus diesen Grund würde ich gerne meine Nas als LiveBuffer für den Timeshift nutzen.

    Die Datei "/usr/sbin/reelvdrd" habe ich wie folgt angepaßt:
    Code:
    GetLivebufferDir () {
        #LiveBuffer enabled?
        if [ $(grep 'LiveBuffer =' /etc/vdr/setup.conf | head -1 | awk '{ print $3 }') = 1 ]; then
            for hd in hd hd0 hd1 hd2 hd3 hd4 hd5 hd6 hd7 hd8 hd9 ; do
                #test for space
                if [ -d /media/.mount0 ] ; then
                    diskfree=`df -l /media/$hd | tail -1 | awk '{ print $4 }'`
                    if [ $diskfree -ge $((1024*1024)) ] ; then  #1GB
                        LIVEBUFFERDIR= /media/.mount0/recordings

    Vielleicht kann mir jemand mitteilen, welche <Änderungen ich noch durchführen muß.

    VielenDank

    Gruß
    Stecki




    EDITed by schlue: code tags eingefuegt
    Angehängte Dateien
    Zuletzt geändert von schlue; 25.01.2014, 15:51.
    AVG I Version 12.12.01 28.02.2013 , 4 GB RAM, 1TB HDD, 1xDVB-S2 Dual, 2x DVB-S2, 1x Netclient2 Version 12.12.01 , 1x Netclient (Version 12.12.), Cisco Gigabit Switch 2008, Fritzbox 7340, Synology DS 212+

  • #2
    Hallo Stecki,
    gibt es das Verzeichnis /media/.mount0/recordings ?

    Solange
    Code:
    diskfree=`df -l /media/$hd | tail -1 | awk '{ print $4 }'`
    genutzt wird, wird vorausgesetzt, dass es eine lokale Festplatte gibt u. es wird getestet, dass auf dieser genuegend freier Platz vorhanden ist.
    Aendere die Zeile in
    Code:
    diskfree=`df -P /media/.mount0 | tail -1 | awk '{ print $4 }'`
    Gruss,
    schlue
    sigpic

    Kommentar


    • #3
      Hallo schlue,

      Danke für Deine Antwort, das Verzeichnis gibt es nicht.

      Ich hatte aufgrund eines anderen Forums-Beitrags. die folgenden Zeilen wie folgt geändert:

      von
      if [ -d /media/$hd ] ; then
      in
      if [ -d /media/.mount0 ] ; then

      und

      von
      LIVEBUFFERDIR=/media/$hd/recordings

      in
      LIVEBUFFERDIR= /media/.mount0/recordings

      den "Diskfree" Eintrag habe ich vorgenommen und den alten auskommentiert.
      Diese Änderung scheint aber nicht gereicht zu haben.
      TimeShift wird mir nicht angeboten

      Viele Grüße
      Stecki
      AVG I Version 12.12.01 28.02.2013 , 4 GB RAM, 1TB HDD, 1xDVB-S2 Dual, 2x DVB-S2, 1x Netclient2 Version 12.12.01 , 1x Netclient (Version 12.12.), Cisco Gigabit Switch 2008, Fritzbox 7340, Synology DS 212+

      Kommentar


      • #4
        Hallo Stecki,
        entferne mal recordings aus der LIVEBUFFERDIR Variable.

        Gruss,
        schlue
        sigpic

        Kommentar


        • #5
          Hallo schlue,

          leider kann ich im den Timeshift immer noch nicht aktivieren.
          Reicht es eigentlich nur aus den Wartungsmode rauszugehen oder muß die Box jedes mal heruntergefahren werden, damit die Änderungen greifen?

          Aktuell habe ich die Einstellungen wie folgt:

          GetLivebufferDir () {
          #LiveBuffer enabled?
          if [ $(grep 'LiveBuffer =' /etc/vdr/setup.conf | head -1 | awk '{ print $3 }') = 1 ]; then
          for hd in hd hd0 hd1 hd2 hd3 hd4 hd5 hd6 hd7 hd8 hd9 ; do
          #test for space
          #if [ -d /media/$hd ] ; then
          if [ -d /media/.mount0 ] ; then
          #diskfree=`df -l /media/$hd | tail -1 | awk '{ print $4 }'`
          diskfree=`df -P /media/.mount0 | tail -1 | awk '{ print $4 }'`
          if [ $diskfree -ge $((1024*1024)) ] ; then #1GB
          #LIVEBUFFERDIR=/media/$hd/recordings
          #LIVEBUFFERDIR= /media/.mount0/recordings
          LIVEBUFFERDIR= /media/.mount0

          Darf man nur einmal ein Anhang pro Thema einhängen?
          Mir fehlt die Möglichkeit eine Datei anzuhängen.

          Viele Grüße
          Stecki
          AVG I Version 12.12.01 28.02.2013 , 4 GB RAM, 1TB HDD, 1xDVB-S2 Dual, 2x DVB-S2, 1x Netclient2 Version 12.12.01 , 1x Netclient (Version 12.12.), Cisco Gigabit Switch 2008, Fritzbox 7340, Synology DS 212+

          Kommentar


          • #6
            Hallo Stecki,
            an dieser Stelle ist der Wartungsmode nicht genuegend da der Prozess reelvdr beendet u. neu gestartet werden muss.

            Bezueglich Datei anhaengen: auf den erweitert Button klicken, dann die Bueroklammer nutzen.

            Gruss,
            schlue
            sigpic

            Kommentar


            • #7
              Hallo,

              leider hat auch das Herunterfahren und der anschließende Neustart nichts gebracht.
              Ich habe mal die Datei "reelvdrd" angehängt.

              Vielleicht habe ich irgendwas falsch gemacht.

              Viele Grüße
              Stecki
              Angehängte Dateien
              AVG I Version 12.12.01 28.02.2013 , 4 GB RAM, 1TB HDD, 1xDVB-S2 Dual, 2x DVB-S2, 1x Netclient2 Version 12.12.01 , 1x Netclient (Version 12.12.), Cisco Gigabit Switch 2008, Fritzbox 7340, Synology DS 212+

              Kommentar


              • #8
                Hallo Stecki,
                entferne das Leerzeichen zwischen LIVEBUFFERDIR= und /media/.mount0.

                Gruss,
                schlue
                sigpic

                Kommentar


                • #9
                  Hallo schlue,

                  das Leerzeichen habe ich entfernt.
                  Inzwischen habe ich alle Variationen durchgetestet und natürlich jedes mal neu gestartet.
                  Leider konnte durch die Veränderungen der Timeshift nicht aktiviert werden.

                  Danke für Deine Unterstützung

                  Viele Grüße
                  Stecki
                  AVG I Version 12.12.01 28.02.2013 , 4 GB RAM, 1TB HDD, 1xDVB-S2 Dual, 2x DVB-S2, 1x Netclient2 Version 12.12.01 , 1x Netclient (Version 12.12.), Cisco Gigabit Switch 2008, Fritzbox 7340, Synology DS 212+

                  Kommentar


                  • #10
                    Hallo Stecki,
                    steht etwas im Systemlog File ( /var/log/syslog ) ?

                    Gruss,
                    schlue
                    sigpic

                    Kommentar


                    • #11
                      Hallo schlue,

                      im Anhang findest Du das Log.

                      Viele Grüße
                      Stecki
                      AVG I Version 12.12.01 28.02.2013 , 4 GB RAM, 1TB HDD, 1xDVB-S2 Dual, 2x DVB-S2, 1x Netclient2 Version 12.12.01 , 1x Netclient (Version 12.12.), Cisco Gigabit Switch 2008, Fritzbox 7340, Synology DS 212+

                      Kommentar


                      • #12
                        Hallo schlue,

                        im Anhang findest Du das Log.

                        Viele Grüße
                        Stecki
                        Angehängte Dateien
                        AVG I Version 12.12.01 28.02.2013 , 4 GB RAM, 1TB HDD, 1xDVB-S2 Dual, 2x DVB-S2, 1x Netclient2 Version 12.12.01 , 1x Netclient (Version 12.12.), Cisco Gigabit Switch 2008, Fritzbox 7340, Synology DS 212+

                        Kommentar


                        • #13
                          Hallo Stecki,
                          es liegt daran:
                          Code:
                          Jan 26 17:01:03 ReelBoxW reelvdrd: LiveBuffer disabled in setup.conf
                          permanent Timeshift ist nicht enabled.

                          Gruss,
                          schlue
                          sigpic

                          Kommentar


                          • #14
                            Hallo schlue,

                            leider ist das mein Problem.
                            Leider steht die Option unter " -> Setup - Videorekorder -> Permanentes Timeshift" nicht zur Verfügung.
                            Der Punkt "Permanent Timeshift" steht auf nein und kann auch nicht geändert werden.
                            Ich habe in der "setup.conf" manuell den Wert "LiveBuffer = 0" auf "LiveBuffer = 1" geändert und dannach neu gestartet.
                            Leider hat das nicht gebracht.
                            Es wird gemeldet., dass eine Festplatte benötigt wird.
                            Es muß also noch eine andere Änderung durchgeführt werden.

                            Viele Grüße
                            Stecki
                            AVG I Version 12.12.01 28.02.2013 , 4 GB RAM, 1TB HDD, 1xDVB-S2 Dual, 2x DVB-S2, 1x Netclient2 Version 12.12.01 , 1x Netclient (Version 12.12.), Cisco Gigabit Switch 2008, Fritzbox 7340, Synology DS 212+

                            Kommentar


                            • #15
                              Hallo Stecki,
                              die Aenderung 0 => 1 hast Du im Wartungsmodus durchgefuehrt ?

                              Es wird gemeldet., dass eine Festplatte benötigt wird.
                              Wann kommt diese Meldung u. wie lautet sie ( genau ) ?

                              Gruss,
                              schlue
                              Zuletzt geändert von schlue; 27.01.2014, 03:58.
                              sigpic

                              Kommentar

                              Lädt...
                              X