Ankündigung

Einklappen
Keine Ankündigung bisher.

LiveBuffer auf erste SSD verschieben

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • LiveBuffer auf erste SSD verschieben

    Hallo Reelgemeinde;

    Habe in meiner AVG III nun 2 SSD Platten, eine mit dem System (250GB, war Auslieferzustand und ist als hd1 gemountet) und nun eine weitere 1TB SSD für die Aufnahmen (als hd3 gemountet) ausgestattet. Der LiveBuffer ist auf der neuen 1TB mit angelegt. Möchte nun den LiveBuffer auf die Systemplatte legen. Beide Festplatten sind gemountet, werden im auch im OSD und auch mit dem mount-Befehl über Telnet angezeigt. Habe in einem Thread hier gefunden, der das Script "reelvdrd" unter anderem zum anlegen des LiveBuffers aufruft.
    Meine Frage nun: Wird das Script "reelvdrd" bei jedem Neustart der AVG aufgerufen und das Verzeichnis für den LiveBuffer definiert? Bei mir bleibt das Verzeichnis immer auf der als hd3 angemeldeten 1TB SSD, obwohl hd1 im Script "reelvdrd" zuerst mit genügend freiem Platz gefunden werden müsste. Wenn ich den Teil des Scriptes über Telnet in einer shell starte zeigt er mir zumindes die hd1 mit genügend Platz an.

    Wer kann helfen?

    Viele Grüsse aus Karlsruhe,

    Theo

  • #2
    Hallo Theo,
    reelvdrd laeuft staendig, solange die AVG eingeschaltet ist.

    Was zeigt die Ausgabe des Befehles
    Code:
    mount
    an ?
    Was ergibt [code]ls -ld /media/hd*/


    Gruss,
    schlue
    sigpic

    Kommentar


    • #3
      Hallo schlue,

      mount zeigt:

      /dev/sda1 on / type ext4 (rw,noatime,nodiratime,errors=remount-ro,commit=30)
      proc on /proc type proc (rw,noexec,nosuid,nodev)
      none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
      none on /sys type sysfs (rw,noexec,nosuid,nodev)
      none on /sys/fs/fuse/connections type fusectl (rw)
      none on /sys/kernel/security type securityfs (rw)
      none on /dev type tmpfs (rw,mode=0755)
      none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
      none on /dev/shm type tmpfs (rw,nosuid,nodev)
      none on /tmp type tmpfs (rw,size=25%)
      none on /var/run type tmpfs (rw,nosuid,mode=0755)
      none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
      tmpfs on /media type tmpfs (rw,relatime,size=10240k)
      /dev/sda2 on /var type auto (rw,noatime,nodiratime,commit=30)
      /dev/sdb1 on /media/hd2 type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
      none on /var/log type tmpfs (rw,nosuid,mode=0755,size=25%)
      rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
      nfsd on /proc/fs/nfsd type nfsd (rw)
      /dev/sda3 on /media/hd1 type ext4 (rw)


      ls -ld /media/hd*/ zeigt:

      drwxr-xr-x 7 root root 4096 2015-09-21 00:21 /media/hd1/
      drwxrwxrwx 1 root root 4096 2015-09-22 20:52 /media/hd2/

      Habe gerade bemerkt, dass die mount-verzeichnisse jetzt hd1 und hd2 sind.

      Werden die nach Reboot neu gesetzt? Gestern waren die Verzeichnisse noch hd1 und hd3
      Nach welcher Regel geht das?
      Zuletzt geändert von Classic; 23.09.2015, 19:00.

      Kommentar


      • #4
        Hallo Theo,
        schau' mal in die /etc/fstab. Dort wird die jeweilige Partition ueber ihre UUID an einen Mountpunkt gebunden.
        Die UUID wird beim Formatieren der Partition vergeben bzw. kann als Label neu vergeben werden.
        D.h. ie UUID bleibt praktisch bestehen.
        Der Mountpunkt ist in der /etc/fstab eingetragen ( entweder manuell ueber editieren der fstab od. ueber das OSD beim Anbinden einer Partition ).

        D.h. wenn sich die Anbindung hd1, hd2 gegenueber hd1, hd3 geaendert hat, hast Du vermutlich zwischendurch ueber das OSD die Festplatte aus-/eingehaengt.

        Gruss,
        schlue
        sigpic

        Kommentar


        • #5
          Hallo Schlue,

          ja, hatte die Platten nohcmal über das OSD aus und wieder eingebunden. Dennoch ist die SSD mit dem niedrigen Laufwerksbuchstaben (hd1) nicht die, die für den LiveBuffer ausgewählt wird. Der ist nach wie vor auf hd2 angelegt und da warden auch die aufgenommenen Filme abgelegt.

          Was kann ich noch tun?

          Grüße,

          Theo

          Kommentar


          • #6
            Auf hd1 gibt es auch ein recordings Verzeichnis?
            sigpic

            Kommentar


            • #7
              hallo schlue,

              ja, es gibt das Verznichis recordings auf hd1

              Und jetzt ist der LiveBuffer auch dort abgelegt.
              Keine Ahnung, warum es vorher nicht funktioniert hat.

              Also erstmal alles ok so. auf hd1 liegt der LiveBuffer und auf hd2 das recordingsverzeichnis und die Aufnahmen.

              Danke für Deine Bemühungen und Erklärungen.

              Grüße,

              Theo

              Kommentar

              Lädt...
              X