Ankündigung

Einklappen
Keine Ankündigung bisher.

Hilfe bei Netzwerkerweiterung erbeten

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • #16
    Hi Schlue
    Über die Kommandozeile im internen Netzwerk klappt es
    Ich denke dann wir es auch über VPN laufen.
    Habe noch Probleme es Über einen Menüeintrag zu starten

    Hier mein Eintrag in der menu_opt.epgneu.inc

    <menu name="EPG neu für Channel 1 2" info="EPG neu für Channel 1 2">
    <command name="epgneu" execute="sudo /usr/sbin/epgscript.sh" />
    </menu>


    Hast du noch eine Idee?
    Attribute stehen auf 755

    LG
    KDS
    AVG III R19502; AVG I R19502; Netclient 1xII R19502 3xI R19431

    Kommentar


    • #17
      Hallo kds,
      sudo ist nicht noetig, da der vdr bereits mit root Berechtigung laeuft.

      Was bei Dir fehlt ist im Beispiel unter http://powersat.de/showthread.php?85...ll=1#post85634 zu sehen.
      Der dort eingesetzte Befehl ( execute="echo /etc/vdr/plugins/setup/mirror-epg.sh | at now" ) benutzt at now, um den Befehl ( das Shell Skript ) mirror.epg.sh im Hintergrund auszufuehren.
      Dies ist noetig, da das Shellskript das OSD sonst offenhalten wuerde. Der vdr wuerde scheinbar haengen bis das Skript ausgefuehrt ist.

      Gruss,
      schlue
      sigpic

      Kommentar


      • #18
        Hi Schlue

        geht beim Netclient I

        leider nicht beim Netclient II und AVG III (ohne internem Netceiver).

        Hast du noch eine Idee.

        LG

        KDS
        AVG III R19502; AVG I R19502; Netclient 1xII R19502 3xI R19431

        Kommentar


        • #19
          Hallo KDS,
          kannst Du naeher beschreiben, was nicht funktioniert ?
          Ueberpruefe einmal, die streamdev Eintraege in der /etc/vdr/setup.conf von AVG I gegenueber AVG II und von NCL II gegenueber NCL I.
          Kann der NCL II Aufnahmen der AVG III abspielen ( mit diesem Test wird sichergestellt, dass die IPv4 Verbindung zwischen NCL II u. AVG III ok ist ).

          Gruss,
          schlue
          sigpic

          Kommentar


          • #20
            Hi Schlue
            Der Befehl fürs EPGScript klappt auf der Kommandozeile (über RCC) auf Netclient I, II und AVG III.
            Die IPv4 Verbindung sollte somit oK sein.
            Es klappt nicht auf derm Menueebene mit

            <menu name="EPG neu für Channel 1 2" info="EPG neu für Channel 1 2">
            <command name="epgneu" execute="sudo /usr/sbin/epgscript.sh | at now" />
            </menu>

            in der epgneu_opt.epgneu.inc

            der Menuepunkt wird angezeigt aber nicht ausgeführt.

            LG
            KDS
            AVG III R19502; AVG I R19502; Netclient 1xII R19502 3xI R19431

            Kommentar


            • #21
              Hi
              schlue
              sudo hatte ich schon weggelassen.
              LG
              KDS
              AVG III R19502; AVG I R19502; Netclient 1xII R19502 3xI R19431

              Kommentar


              • #22
                Zitat von kds Beitrag anzeigen
                Hi Schlue
                Der Befehl fürs EPGScript klappt auf der Kommandozeile (über RCC) auf Netclient I, II und AVG III.
                Die IPv4 Verbindung sollte somit oK sein.
                Es klappt nicht auf derm Menueebene mit

                <menu name="EPG neu für Channel 1 2" info="EPG neu für Channel 1 2">
                <command name="epgneu" execute="sudo /usr/sbin/epgscript.sh | at now" />
                </menu>

                in der epgneu_opt.epgneu.inc

                der Menuepunkt wird angezeigt aber nicht ausgeführt.

                LG
                KDS
                Füge mal einen Punkt (.) direkt vor /usr/sbin.... ein. Also ./usr/sbin/....
                Gruß Henner

                Spiegel - Technisat Satman 85, 2x ALPS Quattro LNB BSTE9,
                Multiswitch - Inverto Unicable IDLP-USS200-CU010-8PP, Spaun 9940NF, Spaun 9800NF (DVB-T Einspeisung, alle MS kaskadiert - 14 DiSEqC, 8 Unicable Anschlüsse),
                ext NetCeiver mit 5 DVB-S2 Tuner, AVG III, NCL II, NCL I,
                NAS QNAP TS-431 mit 3x 3TB WD red

                Kommentar


                • #23
                  Hi Henner
                  Auf der Kommandozeile klappte es mit

                  /usr/sbin/epgscript.sh
                  und
                  /usr/sbin/./epgscript.sh

                  aber beides nicht im Menueintrag auch nicht mit| at.now

                  ./usr/sbin läuft weder auf der Kommanozeile noch im Menueintag

                  Gruß
                  KDS
                  AVG III R19502; AVG I R19502; Netclient 1xII R19502 3xI R19431

                  Kommentar


                  • #24
                    Hallo KDS,
                    an Stelle des sudo sollte/muss echo stehen.
                    Was zeigt der Befehl
                    Code:
                    echo /usr/sbin/epgscript.sh | at now
                    an der Kommandozeile an ? Evtl. wird der Befehl at nicht gefunden, da nicht installiert ?

                    Gruss,
                    schlue
                    sigpic

                    Kommentar


                    • #25
                      Hi Schlue
                      Hier das ergebnis

                      root@ReelBox4:~# echo /usr/sbin/epgscript.sh | at now
                      warning: commands will be executed using /bin/sh
                      job 9 at Wed Jun 22 19:18:00 2016
                      root@ReelBox4:~#
                      AVG III R19502; AVG I R19502; Netclient 1xII R19502 3xI R19431

                      Kommentar


                      • #26
                        Hi Schlue
                        echo ist es.

                        du bist wie immer spitze

                        vielen Dank für deine unermüdliche Arbeit

                        und

                        LG

                        KDS
                        AVG III R19502; AVG I R19502; Netclient 1xII R19502 3xI R19431

                        Kommentar


                        • #27
                          Hi schlue

                          sind wohl doch noch nicht ganz fertig
                          auf dem Netclient I erscheint

                          ReelNetClientA:/usr/sbin# echo /usr/sbin/epgscript.sh | at now
                          -bash: at: command not found
                          -bash: echo: write error: Datenübergabe unterbrochen (broken pipe)

                          at läßt sich mit apt-get install at nicht installieren

                          hast du noch eine Idee
                          LG
                          KDS
                          AVG III R19502; AVG I R19502; Netclient 1xII R19502 3xI R19431

                          Kommentar


                          • #28
                            Hi Schlue
                            auf dem Netclient I geht es auch ohne at Befehl.
                            Sind jetzt durch
                            nochmals Danke
                            LG
                            KDS
                            AVG III R19502; AVG I R19502; Netclient 1xII R19502 3xI R19431

                            Kommentar

                            Lädt...
                            X