Ankündigung

Einklappen
Keine Ankündigung bisher.

2 Aufnahmeverzeichnisse einbinden

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • 2 Aufnahmeverzeichnisse einbinden

    Hallo,


    ich zeichne auf meiner AVGIII direkt auf ein NAS auf.
    Auf dem NAS habe ich zwei Shares die ich auf der AVG über NFS gemountet habe und denen ich beim Verbinden nur bei "Aufnahme" ein ja gesetzt habe.
    Das erste habe ich als Medienlaufwerk für Aufnahmen definiert.
    Bisher hat das auch sehr gut geklappt, das zweite Share tauche unter der Aufnahmeliste als weiteres Verzeichnis auf.
    Jetzt musste mein NAS umziehen und ich bekomme die Einbindung des zweiten NAS nicht mehr hin.
    Das erste ist wie bisher verfügbar, aber es es fehlt in der Aufnahmeliste das Verzeichnis für den zweiten Share.
    Über den Dateimanager auf der AVG kann ich auf das zweiter Share zugreifen. Aber es fehlt in der Aufnahmeliste, um dahin Aufnahmen machen zu können und die dort befindlichen Aufnahmen auch wiederzugeben.
    Was habe ich übersehen?
    Das müsste doch eigentlich reichen, beim Herstellen der Netzwerkverbindungen für beide Aufnahme freizugeben (keine Bilder, keine Musik, keine Videos).
    Ich kann ja auch unter den Medienlaufwerken nur eines für die Aufnahmen aktivieren!?

    Mount:
    Code:
    192.168.179.10:/volume1/reel on /media/.mount6 type nfs (rw,rsize=8192,wsize=8192,tcp,soft,lock,nfsvers=3,retrans=3,timeo=250,addr=192.168.179.10)
    192.168.179.10:/volume1/reel_archiv on /media/.mount2 type nfs (rw,rsize=8192,wsize=8192,tcp,soft,lock,nfsvers=3,retrans=3,timeo=250,addr=192.168.179.10)

    /media:
    Code:
    drwxrwxrwx    5 root root  4096 2014-11-15 21:11 .mount2
    drwxrwxrwx    7 root root  4096 2013-07-04 20:00 .mount6
    lrwxrwxrwx    1 root root    16 2014-11-15 21:14 .RECORDINGS-reel_archiv -> /media/.mount2/.
    drwxrwsr-x    2 root root   120 2014-11-15 21:14 reel
    lrwxrwxrwx    1 root root    14 2014-11-15 21:14 reel_archiv -> /media/.mount2
    /media/reel/recordings (hier sollte das Verzeichnis reel_archiv eingeblendet werden):
    Code:
    root@ReelBox:/media/reel/recordings# ll
    insgesamt 780
    drwxrwsr-x  7 reel reel       4096 2014-11-15 19:28 .
    drwxrwxrwx  7 root root       4096 2013-07-04 20:00 ..
    drwxrwsr-x 12 root ftpusers   4096 2014-11-07 20:13 Comedy
    drwxrwsr-x 84 root ftpusers   4096 2014-11-08 19:31 Kinder
    drwxrwsr-x  8 root ftpusers   4096 2014-11-14 21:13 Musik
    -rw-rw-r--  1 root reel     766967 2013-03-06 03:24 noadonlinestat
    drwxrwsr-x  4 root ftpusers   4096 2014-11-12 19:04 Serien
    -rw-rw-r--  1 root reel          0 2014-11-15 19:30 .update
    drwxrwsr-x  8 root ftpusers   4096 2014-11-15 04:43 VU+_Workshop
    tom
    __________________________________________________ _____________
    AVG III, SSD, 2x dual DVB-S2, 1x DVB-T, unicable, aktuelles Stable
    AVG I, 2TB HDD, 2x DVB-S2, geparkt
    1GB Network, NAS Synology RS810+ (als Aufnahmeverzeichnis)
    Pioneer SC-LX86; Philips LED 46PFL9706

  • #2
    Hallo tom,
    hast Du mal versucht den Link von Hand anzulegen ?
    Gibt es Fehlermeldungen in sysog ?
    Lade bitte mal die /etc/default/sysconfig hoch ( bei SMB/cifs shares koennen dort Passwoerter enthalten sein ).

    Gruss,
    schlue
    sigpic

    Kommentar


    • #3
      Hallo schlue,


      in der syslog steht zwar nicht zur Einbindung des zweiten Aufnahmeverzeichnisses, aber ich habe dort trotzdem eine interessante Feststellung gemacht.
      Auch auf dem verbundenen Aufnahmeverzeichnis gehen die Aufnahmen schief, weil die Berechtigung zum Anlegen des Verzeichnisses fehlt!
      An der Konfiguration der NFS Freigabe für die Verzeichnisse "reel" und "reel_archiv" hat sich eigentlich nichts auf dem NAS geändert!?

      Code:
      Nov 16 11:18:00 ReelBox vdr: [5595] creating directory /media/reel/recordings/Kinder/Happy_Feet_2
      Nov 16 11:18:00 ReelBox vdr: [5595] ERROR: /media/reel/recordings/Kinder/Happy_Feet_2: Keine Berechtigung
      Auch beim Versuch den Softlink anzulegen (als root) erhalte ich die Fehlermeldung, dass die Berechtigung fehlt.
      Code:
      root@ReelBox:~# ln -s /media/reel_archiv/ /media/reel/recordings/reel_archiv
      ln: Erzeuge symbolische Verknüpfung â/media/reel/recordings/reel_archivâ: Keine Berechtigung
      Hier die sysconfig:
      Angehängte Dateien
      Zuletzt geändert von tom_ff; 16.11.2014, 11:59.
      tom
      __________________________________________________ _____________
      AVG III, SSD, 2x dual DVB-S2, 1x DVB-T, unicable, aktuelles Stable
      AVG I, 2TB HDD, 2x DVB-S2, geparkt
      1GB Network, NAS Synology RS810+ (als Aufnahmeverzeichnis)
      Pioneer SC-LX86; Philips LED 46PFL9706

      Kommentar


      • #4
        Hallo tom,
        sieh mal bei den Berechtigungen auf dem NAS nach, ob diese wirklich noch so sind, wie gewollt.
        Welche Einstellungen stehen dort zur Verfuegung ?

        Gruss,
        schlue
        sigpic

        Kommentar


        • #5
          Nicht vergessen, über NFS werden die Zugangsberechtigungen per IP Adresse vergeben.

          Sind die alle gleich geblieben ?
          AVG II, TL-62 Dual Core, 2GB Ram, BM2LTS,Quellauflösung an Panasonic 55VT30
          AVGIII, testing SVN an Panasonic 55VT50E
          AVG II, Serienprozessor,2GB,BM2LTS an Toshiba LCD TV
          AVGII, Serienprozessor, 2GB, SVN testing an Sony LCD TV
          Netcv1: 3xDVB-C , Netcv2: 6x DVBS2 , Netcv3: 5x DVBS2
          Sky HD und HD+ Abo

          Aufnahmen auf NAS QNAP-TS439 Pro II mit RAID 5 (4x2TB)
          HP Procurve 1810-24 mit VLAN
          Lite RCX 500GB, mit HDE, (derzeit geparkt)

          Kommentar


          • #6
            Ich glaube, ich habe das Problem gefunden!
            Auf dem NAS gab es eigentlich keine Änderungen. Der IP-Adressbereich ist für die NFS-Clients freigegeben.
            Da ich Berechtigungsprobleme beim Anlagen des Softlinks und auch beim Anlegen von Aufnahmen hatte, habe ich mit das eigentliche Aufnahmeverzeichnis vorgenommen.
            Ich habe es in den Netzwerkverbindungen getrennt und neu einbunden. Das Problem war zunächst wieder da.
            Dann habe ich es nochmals getrennt und unter einem neuen Namen eingebunden! Zuvor hatte ich "reel" benutzt, jetzt "nas_reel". Uns schon funktioniert es!
            Meine Vermutung ist, dass es mit dem Namen "reel" Probleme gab, da ja der gleiche Name vom System bereits als Medienverzeichnis genutzt wird.
            Damit hingen dann wahrscheinlich die Rechteprobleme zusammen.
            Jetzt geht es wieder!

            Danke.
            tom
            __________________________________________________ _____________
            AVG III, SSD, 2x dual DVB-S2, 1x DVB-T, unicable, aktuelles Stable
            AVG I, 2TB HDD, 2x DVB-S2, geparkt
            1GB Network, NAS Synology RS810+ (als Aufnahmeverzeichnis)
            Pioneer SC-LX86; Philips LED 46PFL9706

            Kommentar

            Lädt...
            X